This has Now Officially Become an Obsession! More Revive Ad Server Testing.

johnpauljones
I have not yet begun to test!

After having tried several versions of the Revive Ad Server software on the Chuwi HiBook Tablet the last week or so, I reached the conclusion that it was not going to work.

However, because I hate to have a mystery on my hands, I went ahead and installed the latest Release Candidate onto the Asus Notebook version of THE Tablet Test Server here and it has been up and running for almost 24 hours with not a single glitch. No errors in Apache at all, none, zero, zilch. Configuration wise these 2 platforms are running the identical virtual machine. The only differences being that the notebook is a mere dual core Intel Celeron running at 1.6 GHz and the tablet has a Quad Core Z8300 Intel at 1.44GHz, which should be, in theory, a more powerful CPU. The allocated ram on the Asus Notebook was bumped to 1.9 gb versus the tablet running at 1.7 gb, but memory was never the issue at all.

So while this is not technically “tablet” related, it is related because we are finding out if it is a hardware issue or a software issue. That and I just hate to surrender too easily. Any advert prepended with “Shop Gearbest” is being served via the Revive software.

Tim

--------------------------------------------------------------------------------------
This site currently runs on either a Chuwi HiBook tablet or eventually my Chuwi Hi12 tablet. Check the About page for details. Registration without participation will result in termination.

Revive Ad Server Issues Continue. Installed the Latest Release Candidate and Issues Appear to be Resolved.

bang-head-on-wall1So yesterday I re-installed the latest stable release of the Revive Ad Server and by the end of the day I noticed that I was getting PHP errors in my Apache server error log.

By this morning the server had ceased to deliver banners even after a server reboot, cleaning out the cache, restarting the MySQL server and restarting Apache several times. It is now working again, but is no longer being used to serve any adverts at least by me. The test account is still active.

So this time I gave up on the version 3.2.4 and moved on to version v4.0 RC1, the release candidate.  So far with the same ads running on both this web site and my other site, there has yet to be a single error in Apache. This version does not have a test user account on it and will not have one until I see a few days of stable operation.

I am unclear why the latest stable version did not work and I am not going to dwell on it. Perhaps the download was corrupted or perhaps there is a bug in that version. But I hate to give up, so I went with the latest version.

Once again time will tell and after all this is simply a test server and that is what this project is.

Update: 23:36 hrs – Once again…I have been foiled! In a mere 5 hrs I began to see errors in my server logs and finally no banners/ads delivered! Did I give up? Of course not! I went back to the version,(3.2.2), that is running fine on 2 other servers, although, those sites are on an actual PC and not a tablet…but…time will eventually tell us the whole story!

Tim

--------------------------------------------------------------------------------------
This site currently runs on either a Chuwi HiBook tablet or eventually my Chuwi Hi12 tablet. Check the About page for details. Registration without participation will result in termination.

Chuwi HiBook and the Revive Ad Server: Had to do a Re-Install

revive-login1Last week I installed the Revive Ad Server Software onto this server here and it functioned well for a few days.

However, lately I was seeing a ton of error messages  in my Apache server logs and banners quit showing or worse yet I was getting Internal Server Error (500) messages.

So I went ahead and completely reinstalled the software, but not before taking a few precautionary steps. First I made sure that the web server account owned the directory that I was installing to. Next I increased the PHP memory limit to 128 MB. Then I ran a clean install to a new directory and an empty database.

So far it appears to be working quite well, although time will tell. I am still a bit confused by the installation instructions that tell me the install will tell me which directories need to have permissions changed. That particular information does not come up during the installation, (previous versions I tried on other servers did have this info), nor is there much info available in the release notes nor the read-me file. So far I left permissions set just as the installation file set them.

I also recreated the testuser account for anyone wishing to play with the software. See this article for more info.

I certainly would appreciate any feedback from folks trying out the ad server or just any general feedback on how the ads are functioning.

Tim

--------------------------------------------------------------------------------------
This site currently runs on either a Chuwi HiBook tablet or eventually my Chuwi Hi12 tablet. Check the About page for details. Registration without participation will result in termination.

Sometimes a Battery Powered Server is a Great Idea! (Especially in Sub-Standard Infrastructure Kentucky)

aging-infrastructureSo today was a typical Kentucky Saturday with nice warm temperatures and a complete failure of the local MediaCom Cable service.

That was quickly followed up by a power outage, which killed my primary Dell server.  So here I sit 25 miles away and the only thing I can update or post to is my trusty Chuwi HiBook. Why is that?,  you might ask. The answer is quite simple, this server runs on a tablet and is running happily along on battery power with more than 75% power remaining.

The Dell however can’t magically turn itself back on. Well it could, but I forgot to setup the port forwards for my Wake on LAN app on my phone.

So this will suffice for now and this is all I have for the HiBook News this weekend.

Tim

--------------------------------------------------------------------------------------
This site currently runs on either a Chuwi HiBook tablet or eventually my Chuwi Hi12 tablet. Check the About page for details. Registration without participation will result in termination.

Contrary to My Better Judgement I Have Created a Test Account for Those Interested in Revive Ad Server

revive-testuser1

 Updated: this software test has ceased, so you can ignore this post.

Today I setup a user account for folks to play with the Revive Ad Server software. Of course this software will only function when the site is on the HiBook VM version of the server. Look at the header image and if it doesn’t say “Tomcat” in the lower right, this ad server software will not be installed and functioning.

The login is testuser and the password is also testuser. Be aware, if you try to fill the server up with ads, the account will be deactivated. If you change the password, the account will be deactivated. Play nice, don’t be an asshat and ruin it for those who might be truly interested.

That is all,

Tim

--------------------------------------------------------------------------------------
This site currently runs on either a Chuwi HiBook tablet or eventually my Chuwi Hi12 tablet. Check the About page for details. Registration without participation will result in termination.